Star InactiveStar InactiveStar InactiveStar InactiveStar Inactive
 

Hello,

 

I'm get bored with Fritzbox and decided to swtich on OpenWRT - it is where the short story begin..

I have small travel router with OpenWRT installed, GL MT300N second version with OpenWRT, below you can find configuration to have internet via this device or simular with OpenWRT.

Here is the configuration for VLAN ID 35 used by Tango Fiber, MAC address was not spoofed. Thank you for network background, It helps a lot =)

 

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '***'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.8.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan'
        option ifname 'eth0.35'
        option _orig_ifname 'eth0.35'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'username'
        option password 'password'
        option ipv6 'auto'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 6t'

config switch_vlan
        option device 'switch0'
        option ports '0t 6t'
        option vlan '35'

 

I hope it helps somebody.

Add comment


Security code
Refresh